Revenera Usage Intelligence: Service Disruption to Recent Custom Events View and Custom Events Archive Download

Incident Report for Revenera System Status Dashboard

Update

We are continuing to work on the server enhancements and will share additional information as it becomes available.
Posted Jul 28, 2026 - 09:56 PDT

Identified

The issue affecting the Recent Custom Events view and the ability to download Custom Event Archives has been resolved.
While data collection remains unaffected, the generation of Custom Event Archives has been temporarily paused until we've completed server enhancements. We will provide an update once these enhancements are complete and archive generation has resumed.
Posted Jul 27, 2026 - 10:16 PDT

Investigating

We are currently experiencing an issue affecting the Usage Intelligence Custom Events functionality, specifically the Recent Custom Events view and Custom Events Archive downloads. Our team is actively investigating and working to resolve the issue. We will provide updates as more information becomes available.
Posted Jul 27, 2026 - 07:33 PDT
This incident affects: Usage Intelligence.