FlexNet Operations ALM 2025.05 Release Reverted in Production (NAM2) Environment

Incident Report for Revenera System Status Dashboard

Postmortem

What Happened:

The monitoring we have in place detected an increase in error messages appearing in the Production (NAM2) system logs. Since these errors began appearing around the completion of the FlexNet Operations 2025.05 release Production deployment, we performed a rollback of the release for this environment only as a precautionary measure.

This mitigation approach enabled the team to assess the potential scope of impact, identify the root cause and possible fix, and avoid any disruption impact to our customers’ business.    

Customer Impact:

  • Only FlexNet Operations ALM customers whose tenants run in the Production (NAM2) environment were temporarily reverted to the previous release.
  • No service disruption occurred during the rollback process.

Resolution:

Upon investigation, we found the additional messages in the system logs were the result of an erroneous configuration. The configuration has been corrected and validated, and we’ve redeployed the FlexNet Operations 2025.05 release to the Production (NAM2) environment.  

Next Steps:

  • We continue to monitor the Production (NAM2) environment for errors.
  • Additional validations will be implemented to the release process to better identify these types of issues pre-release.
Posted May 15, 2025 - 10:12 PDT

Resolved

We’ve identified and resolved the issue that resulted in rolling back the FlexNet Operations 2025.05 release. The fix was validated, and the FlexNet Operations 2025.05 release was redeployed to the Production (NAM2) environment. We’ll continue to monitor the environment to ensure no further issues occur.
Posted May 15, 2025 - 10:05 PDT

Identified

Please note: The following notice is applicable only for those tenants who are on the FlexNet Operations ALM Production (NAM2) environment.
All other FlexNet Operations ALM Production (NAM/EU) and FlexNet Operations LLM Production environments are not impacted by this issue and can disregard this notice. The unaffected environments remain on the 2025.05 release.

We've identified an issue in the FlexNet Operations ALM Production (NAM2) environment and have reverted the FlexNet Operations ALM 2025.05 release for that environment.

The team is actively working to resolve the issue and will redeploy the FlexNet Operations ALM 2025.05 release to the Production (NAM2) environment once the fix has been validated. We will share the updated FlexNet Operations ALM 2025.05 release date for Production (NAM2) as soon as it is finalized.

If you have any questions, please contact Revenera Technical Support for assistance.
Posted May 14, 2025 - 11:14 PDT
This incident affected: FlexNet Operations ALM Production NAM2 (FlexNet Operations ALM End User Portal NAM2, FlexNet Operations ALM Producer Portal NAM2, FlexNet Operations ALM/LLM Cloud Device Activation Service NAM2, FlexNet Operations ALM/LLM Cloud Licensing Service NAM2).